Home/Support/Support Forum/Will support for 64-bit development environments be added?
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Will support for 64-bit development environments be added?

0 votes
That's a pity; we use Netos in (relatively undemanding) real-time applications where I have concerns as to the suitability of Linux (quite apart from the learning curve and porting effort involved in a new system).
Are there any plans to make the development environment work properly on 64-bit platforms without workarounds? (There was mention of a new release in Q2 this year in these forums, but no sign of anything so far). And use of a more recent version of Eclipse would be helpful, if only because other platforms use it.
related to an answer for: Future NETOS support
asked Oct 27, 2016 in Embedded Devices by steved2 Seasoned Professional (151 points)

Please log in or register to answer this question.

2 Answers

0 votes
There is no current plans for this. Netos works on x64 platforms in most cases with no workarounds
answered Nov 5, 2016 by LeonidM Veteran of the Digi Community (3,028 points)
I've finally found a little time to revisit this, and for me the development environment doesn't work on Windows 7 64 professional.
The installation is up to date as of today, according to Package Manager.
On doing a clean and build of an existing project, the process hung.
On the three attempts made, cygwin's cp.exe appeared to be the culprit, being the only 'non-standard' process running that I could see. It also proved impossible to kill this program - in the end a power down was the only way forward.
The parameter list passed to cp.exe, as shown in Process Explorer, appeared to be truncated in mid-command; whether this was because of a limit in PE, or because of inadequate memory to pass the parameters, I couldn't say.
The version of cygwin is that supplied.
I've set the relevant executables to XPSP3 compatibility mode.

Any suggestions?
>I've set the relevant executables to XPSP3 compatibility mode.
This should not be required. Only thing I had to change is to run DigiESP as Administrator in comptibility settings.
Have you installed Netos as admin user? Are you starting DigiESP as administrator? All our Netos machines are 64bit at this point. I am using Win10 Pro x64 with Netos on a daily basis.
0 votes
I've had another look at this, and it appears that I've been asking the wrong question! Certainly when I looked, the only FAQ I found related to doubts about running on 64-bit systems. It appears from your reply that the problem is more one of permissions on newer systems.
As far as installation of Net+O/S is concerned, I would have installed as administrator only if specifically prompted to do so. (I have another Eclipse-based development environment which required only normal user permissions to install and run, so wouldn't have automatically used administrator levels).
I would certainly not expect any need to run 'ordinary' software as an administrator; quite apart from possible security risks, it causes major problems with file permissions - all our project files are on shared servers, so if they are saved with administrator ownership, noone else can access them (including me when running from a different machine!)
What actually 'needs' administrator privileges for everything to work?
answered Apr 28, 2017 by steved2 Seasoned Professional (151 points)
...