Home/Support/Support Forum/How to unlock uart

How to unlock uart

0 votes
I figured my XBee was bricked and tried to update my XBee firmware using a Sparkfun USB explorer, and I got this message >>File 'xb24_15_4_10ee.ehx2' appears to be corrupt, its size is too small. Please contact support<< Please what do I do?

I checked the release notes for my current firmware and was informed that Tx at the wrong Baud rate could cause 'uart' to lockup. I don't know what to do, I got the shield just yesterday and tried to figure it out.
asked Oct 28, 2016 in RF Solutions and XBee by KSMLink New to the Community (0 points)

Please log in or register to answer this question.

2 Answers

0 votes
This error message appears to be related to XCTU software's library and not pointing to any UART issue.

I suggest you to either manually download correct FW file from Digi website and replace it in library or reinstall XCTU to overcome this issue.
answered Nov 7, 2016 by asgm Veteran of the Digi Community (1,499 points)
0 votes
asgm thanks for answering. gonna try what you recommended
answered Nov 29, 2016 by Hisheight New to the Community (1 point)