Home/Support/Support Forum/How to disable CLI on Serial 0 for WR21
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

How to disable CLI on Serial 0 for WR21

0 votes
I am using a WR21 to accept a telnet connection and access a device connected to Serial 0. The connection works great, but after I disconnect, the connected device is sending some data to the serial port which gets interpreted as a bad login by the Digi. The Digi logs the invalid password and responds out Serial 0. The connected device is then also looking for a valid login, so it also responds with invalid password, creating an endless loop. I don't need the command line interface on Serial 0, so is there a way I can disable it?
asked Nov 29, 2016 in Digi TransPort by sulliwk06 New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
Log into the device via the web, SSH or telnet and run the command "cmd 0 cmd_processor off" to stop the WR21 listening to commands on the serial port. Don't forget to "config 0 save" to save the config.

Even though the WR21 is not listening for commands you can still connect to the serial port via a TCP socket.
answered Nov 30, 2016 by NicholasWilson Veteran of the Digi Community (1,003 points)