Home/Support/Support Forum/Disable multihopping in XBee Pro S2

Disable multihopping in XBee Pro S2

0 votes
Hello.

I would like to measure RSSI of XBee transmitters. I am using the DB command, which returns RSSI in decibels of the last received packet. The multihopping feature is disturbing my measurements since the RSSI returned by the DB command is RSSI of the last hop. Is there a way to disable multihopping?

I tried setting the Radius parameter of the Transmit request message (frame type 0x10) to 0, but that is a special value for this parameter, meaning "use the maximal possible value", so that did not help. If I set it to 1 does it mean "no hops" or "only direct communication between two devices"? Or does 1 mean "one hop" or as I would understand it "there can be one intermediate device"? Does this effect only broadcast transmissions? If so, how to disable hopping for directly addressed transmissions?

Thank you for your answers.
asked Dec 5, 2016 in IEEE 802.15.4 by Matouš New to the Community (3 points)

Please log in or register to answer this question.

1 Answer

+1 vote
Set the BH and NH to 1.
answered Dec 5, 2016 by mvut Veteran of the Digi Community (11,298 points)
Thanks for your answer... What do you mean by BH and NH? Do I set that with an AT command? Or is it a firmware parameter?

EDIT: OK, I see that there are firmware parameters called NH and BH, which I had set to 30 and 0. Could you please point me to some documentation regarding these parameters?
But doesn't this only limit the number of hops to one? Which means that it will still hop and thus the RSSI reading will be invalid?
The number of hops includes the initial transmission. So setting it to 1 tells it to send the data packet. Having a value of 1 tells the receiver not to forward it on.
Thank you very much for clarifying. The documentation I found regarding this was very unspecific. I will try it with this setting at the first opportunity.
...