Home/Support/Support Forum/XCTU + XBEE + SCAN devices

XCTU + XBEE + SCAN devices

0 votes
I have a XBEE module in Transparent mode. (ATAP 0)

Let's say that this XBEE module is on channel 3 (ATHP 3) and that it is currently adressing another module XBEE module. (Ex: ATDH 3A200 and ATDL 41040600). In short, two modules are communicating to each other in transparent mode.


Now, I would like a third XBEE module to find all the XBEE modules in the area. Can I do that with the transparent mode. By default, this third module is on channel 1. It seems the ATND is not working when in transparent mode. I don't see the other devices.

Is it because the XBEE is on the wrong channel ?
(I also tried ATHP 3 and it is not working)
or
Is it because ATDH/ATDL is set to a specific address ?


I did the same SCAN with XCTU in API mode and I was able to see all devices.

Can somebody tell me why the SCAN is working in API mode but not in transparent mode ?

Is there a way to find all devices on all channel (independently of their ATDH/ATDL values)

Thanks for your comments.
asked Feb 3, 2017 in DigiMesh Proprietary Mesh Networking by ssinfod New to the Community (6 points)

Please log in or register to answer this question.

1 Answer

0 votes
It is dependent on which XBee modules you have and what functions they offer. For example, I can't use an XBee PRO 900 HP to locate any XBee/XBee PRO S2C modules. The reason for that is they operate over different protocols, frequencies and data rates.

What are the three modules in question you are using and what firmware versions is installed on each?
answered Feb 6, 2017 by mvut Veteran of the Digi Community (15,413 points)
For my example, all the modules are the "Digi XBee® 868LP"
https://www.digi.com/products/xbee-rf-solutions/embedded-rf-modules-modems/xbee-868lp
For the ND to work, they all must be on the same channel mask, and PAN ID. They must also be in range. IF a sleeping network is used, then you must also use the same sleep settings and be within range to sync up with that network.
...