Home/Support/Support Forum/XB24C recovery failure

XB24C recovery failure

0 votes
My two XB24C modules worked perfectly fine yesterday, but when i connected them to my laptop today XCTU couldnt read Hardware and Firmware data.

Then i tried recovering them (XB24C - ZIGBEE TH Reg - 4059) and it said
"– Resetting and entering bootloader… [ERROR]
There is not an active bootloader in the module."

Can anyone help me please?
Could that be caused by the fact that i changed the mode to API yesterday?

Thxalot for helping in advance
asked Feb 23, 2017 in RF Solutions and XBee by Breiti New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
Generally no that would not cause that.

How are you connecting the radios to the PC? What are you connecting them to?

What is the Full part number of the radio in question? It should be something like XBP24CZUIT-004.
answered Feb 27, 2017 by mvut Veteran of the Digi Community (15,413 points)
No, an official board just means that you can connect the XBee to the Arduino and know that it will work that way.  Not that you can connect the XBee to the PC.
Can you recommend me any way to connect the XBee to the PC?
Sure, try using a Development board such as the XBIB-U-DEV or Xbee Grove board.
I guess these XB24C modules will now just be forgotten in one of my drawers... SCREW THEM!! :P
Thank you so much for all the help and if there might be any way to PM you pls let me know :)
If it was me, I would spend the $20 or so an simply get the Grove board.