Home/Support/Support Forum/New PC/new Digi ESP installation, old project - won't run on my device anymore
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

New PC/new Digi ESP installation, old project - won't run on my device anymore

0 votes
I have an old project I'm trying to make a change to. It was written in:
Digi ESP for NET+OS
Version: 1.4.0
Build id: 03132009 NET+OS 7.4.2

It compiles, but when I attempt to run the firmware on my ConnectCore 9p 9215, it dies as soon as I try to write data to flash memory. At least, that is my assumption based on the continuous flashing of LE2.

I should also mention I had all this working fine on my old hard drive, but that drive died and I had to make a new installation of Digi ESP. That is where I encountered the above problem.

I remember when we first built this project, I had to download several updates for Digi ESP, but now when I check for updates, I get the following errors:

Network connection problems encountered during search.
Unable to access "http://jumpstart.digi.com/assets/esp/netos74".
Unable to access site: "http://jumpstart.digi.com/assets/esp/netos74" [Server returned HTTP response code: "307 Temporary Redirect" for URL: http://jumpstart.digi.com/assets/esp/netos74.]
Unable to access site: "http://jumpstart.digi.com/assets/esp/netos74" [Server returned HTTP response code: "307 Temporary Redirect" for URL: http://jumpstart.digi.com/assets/esp/netos74.]
Unable to access "http://update.eclipse.org/updates/3.1".
Unable to access site: "http://update.eclipse.org/updates/3.1" [Server returned HTTP response code: "403 Forbidden" for URL: http://update.eclipse.org/updates/3.1.]
Unable to access site: "http://update.eclipse.org/updates/3.1" [Server returned HTTP response code: "403 Forbidden" for URL: http://update.eclipse.org/updates/3.1.]
Unable to access "http://download.eclipse.org/tools/cdt/releases/eclipse3.1".
Unable to access site: "http://download.eclipse.org/tools/cdt/releases/eclipse3.1" [Server returned HTTP response code: "404 Not Found" for URL: http://download.eclipse.org/tools/cdt/releases/eclipse3.1.]
Unable to access site: "http://download.eclipse.org/tools/cdt/releases/eclipse3.1" [Server returned HTTP response code: "404 Not Found" for URL: http://download.eclipse.org/tools/cdt/releases/eclipse3.1.]

Right now, the only thing I'm certain of is that my old installation had the updates, but my new one does not. So, does anyone have suggestions on how I can get the old updates?
asked Feb 27, 2017 in NET+OS by burl New to the Community (17 points)

Please log in or register to answer this question.

1 Answer

0 votes
looks like Digi package manger server is down. If you copy your Netos74 folder from old HDD to a new machine you will inherit all the updates. Also it's recomended to upgrade to Netos 7.5 as Netos 7.4 is very old.
You should open a support case for the Package manger issue.
answered Mar 2, 2017 by LeonidM Veteran of the Digi Community (2,821 points)
...