Home/Support/Support Forum/xbee S2C loopback testing not working

xbee S2C loopback testing not working

0 votes
I am using 2 xbee S2C modules for my project, one is connected to PC via USB, and other is remote.
When testing two modules between PC to PC by connecting both modules to two PCs, the communication works fine.
But, when one module with PC and other given power through adaptor, the loopback test is not working.
power and Assoc LED are glowing in both modules,
when sending data from PC, RSSI Led in both modules (PC and remote) glows, TX lED glows in PC module, while both RX and TX modules were off in the remote xbee
but when I try to remove the jumper (loopback) between DIN and DOUT, the RX LED glows in the remote..

I dont know how to solve this remote xbee to make transmit the data back.

please help..
Thanks in advance
asked Mar 9, 2017 in IEEE 802.15.4 by hameed New to the Community (1 point)

Please log in or register to answer this question.

2 Answers

0 votes
What firmware versions are you working with?

Is API mode enabled on either one?

Do you have a loop back adapter connected on the remote radio or not?

Are you using the Loop back Cluster ID function or the Adapter function in XCTU?
answered Mar 9, 2017 by mvut Veteran of the Digi Community (11,445 points)
Dear MVUT

1. The firmware version is Modem firmware version:405F, Modem type:XB24C,
2. API mode is not enabled on both modules
3. Loopback is done by using jumper wire between DIN and Dout
4. I donot understand cluster ID function or the adapter function in Xctu, where to look for it??
by the way Im using Xctu (older version) in windows XP
0 votes
Dear MVUT

1. The firmware version is Modem firmware version:405F, Modem type:XB24C,
2. API mode is not enabled on both modules
3. Loopback is done by using jumper wire between DIN and Dout
4. I donot understand cluster ID function or the adapter function in Xctu, where to look for it??
by the way Im using Xctu (older version) in windows XP
answered Mar 13, 2017 by hameed New to the Community (1 point)
First off, set the DL and DH of the Coordinator to the SL and SH of the router.  Next, make sure that the router is associated to the coordinator (AI0, ID, OP and OD are the same on both). Set the data receive timeout in XCTU's Range test to 5 second from 1 second.
...