Home/Support/Support Forum/AR command makes a large route record indicator message contiunously
New and improved user forum site coming soon

AR command makes a large route record indicator message contiunously

0 votes
Your manual shows like this.

AR (Aggregate Routing Notification)
This command applies to the XBee/XBee-PRO ZigBee RF Module.
Set or read the periodic time for broadcasting aggregate route messages. If used, these messages enable many-to-one routing to the broadcasting device. Set AR to 0x00 to send only one broadcast, to 0xFF to disable broadcasts, or to other values for periodic broadcasts in 10 second units.

I set AR 0 (once) or AR 6 (once every 60 seconds).
Then my coordinator got a lot of route record indicator (0xA1) messages continuously.
They were more than my sensor's report messages..
It didn't stop.
It was not that I expected...
I set AR FF...But it didn't disable broadcast...
My coordinator still got a lot of route record indicator (0xA1) messages continuously.
It was not that I expected, too.

I set NR 1 , then it stopped....

How can I use AR command?
If I made a mistake, let me know that..
asked Mar 24, 2017 in RF Solutions and XBee by hwjang11 (-1 points)
edited Mar 24, 2017 by hwjang11

Please log in or register to answer this question.

1 Answer

0 votes
With AR enabled, the coordinator will broadcast an AR update every AR*10 seconds to update the routing tables. However, any communication will also automatically include a routing message.
answered Mar 24, 2017 by DystopianFerret Veteran of the Digi Community (368 points)
I want to use AR command to update the route table.
I think it works well.
But when I disable AR command (AR FF),
I don't want to get a lot of route record indicator (0xA1) messages any more.

How can I do that?
You must reset the network using an ATNR command
If I use ATNR command, the route information of the router is cleared....It's not what I want.
...