Home/Support/Support Forum/Wifi module not acting on 0x07 - Remote AT command packets, to set DIO2 high

Wifi module not acting on 0x07 - Remote AT command packets, to set DIO2 high

0 votes
I can set the DIO2 pin to high or low using the XCTU software. And that change is then displayed on my 3.3 volt powered breadboard, when the module is then plugged into it. I also have Led's attached to the RSSI and associate pins.

Am using a terminal program called Hercules to send packets from my computer, through my wifi router, that I've created with the XBEE "frames generator" tool - to the module, when the module is plugged into my breadboard. Also running a piece of amazing software called WireShark, that captures and displays all IP traffic between my computer and the module. It looks like I've set up my router forwarding table correctly, cuz when I send the command sequence - 7E 00 0E 07 01 00 00 00 00 C0 A8 00 FE 02 44 32 05 14 WireShark reports that it is the intended data being transmitted - to set the bit high.

The modules "associate" Led is blinking, and my routers status page shows that the module is in communication with my wifi router. The RSSI Led comes on for a few seconds, every time I send a string of TCP data to it, to indicate that packets have been received.
The WireShark software shows that the intended data was sent, and it shows a TCP Acknowledge packet was received by my computer as a response from the Xbee WiFi module.
But still that IO pin isn't able to be controlled remotely using the TCP protocol.

Here are some critical module parameters that have been set with the XCTU software:
AH - infrastructure
CE - STA mode
IP - TCP protocol
D0 - device options 0
AP - API mode without escapes
AO - XBEE API Rx indicator

WiFi module with latest 2026 firmware.

Anybody have some insight into this?
asked Apr 3, 2017 in IEEE 802.11 (Wi-Fi) by tombot520 New to the Community (0 points)
edited Apr 2, 2017 by tombot520

Please log in or register to answer this question.

1 Answer

0 votes
What port number are you sending this frame to?
answered Apr 3, 2017 by mvut Veteran of the Digi Community (11,298 points)
The module is default set to 0x2616 port number and so I am setting the hercules terminal program to sent to the port with that hex value.
I am sending to the 0x2616 hex port number.
The address of the module is 192.168.0.254 on my net.
...