Home/Support/Support Forum/Problem with Pin-Sleep

Problem with Pin-Sleep

0 votes
Hello,
(Using Five "Xbee Pro 900HP")
I am trying to put one of the modules to sleep using the SM sleep mode setting DIO8. (connecting pin 9 to 0 Volt.)
Then, when I use the Node discovery function ATND, I am still discovering the module I put to sleep.
Are there any other settings I am missing? It works fine on the Xbee 2.4Gz units I used previously.

Thanks,
GerrySC
asked Jun 12, 2017 in RF Solutions and XBee by gerrySC New to the Community (2 points)

Please log in or register to answer this question.

1 Answer

0 votes
Gerry, what are you setting the SM command to?

What are you sending the ATND command from or on?
answered Jun 12, 2017 by mvut Veteran of the Digi Community (15,107 points)
Module_1: SM = Normal[0]
Module_2: SM = Async. PinSleep[1]
Module_3: SM = Async. PinSleep[1]
Sending the ATND command from Module_1
I am testing the units using the XCTU program

I figured out that if I disconnect Module_2 or Module_3 from XCTU then the module that is disconnected is not recognized or recognized depending of the state of the Sleep-Pin.

I wonder if there is a bug in the XCTU program?
I am not sure if I would call it a bug or if it is a feature that XCTU is reporting all units physically connected when the ND Command is issued.  Now that may also change on how you use the ND command. That is, if you use the network discovery function in XCTU or if you go to the terminal window, manually enter command mode and issue the ATND command.
...