Home/Support/Support Forum/How to configure xtend 900 devices for multiple UAV's talking to one ground station

How to configure xtend 900 devices for multiple UAV's talking to one ground station

0 votes
Hello, we want to learn what is the best configuration to our RF communication problem using XTP9B-DMS-001 devices. There are four RF devices, one of them is connected to pc as ground station and three devices are connected to three UAV's. We want to communicate from each UAV with ground station, simultaneously and bidirectional. No communication is needed between UAV's. UAV's are sending data (Mavlink messages) to ground station very frequent and continuous. Ground station is sending little amount of data. Our goal is to obtain maximum throughput and minimize delay. We want to avoid interference between UAV's. UAV's are sending data too much and this causes For our problem, we want to learn which protocol is best suited ? For example point to multipoint or digimesh. And which modes we should use, API or transparent? Should we buy another product for ground station, like RF modem? Can we configure devices to use different frequencies or let them talk simultaneously? We want to learn what is optimal configuration and devices other is needed for our problem.
Thanks
asked Aug 1, 2017 in XTend by asoyyigit New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
That is nothing more than a classic point to multi-point configuration.

Base: DT FFFF MY 1

Remotes DT 1 MY unique

Just remember that this is a Half duplex product. It can either send or receive. Just not at the same time.
answered Aug 1, 2017 by mvut Veteran of the Digi Community (11,302 points)
Thanks for your answer, we changed the firmware of devices to 2004 hopping instead of Digi mesh and tried using polling mode. We set the ground station to be the base with address MY 1000 and poll remote addresses from PB 1001 to PE 1003. We tried to send 100 packets from remote to the base using API mode but only some of the packets arrived like 5 26 90 etc.. We set Minimum polling delay to 0xFFF in remote so no packages should be discarded, and set 0xA to the base. What are we doing wrong, what should be the correct configuration and delay values for base and remotes? We don't want to hang more than 10 milliseconds if a remote is not available.
We tried to enable ACK and all of the messages got to the destination, isn't there any way to do this without ACK because we don't want overhead.
You don't intermix API mode and Polling mode. You need to use one or the other.
So are you telling me that I must use transparent mode if I am using polling mode? But how am I going to send data to different remotes from the base in transparent mode? Can you explain in detail which modes should I use for base and remotes
That is correct.  You must use transparent mode if you are going to use polling mode.

Polling mode is done on a time basis. Each node starting with the first node in your address list gets a time slot determined and set by you. All the addresses or nodes will have the same time frame to respond or communicate in.
...