Home/Support/Support Forum/Unable to update property /wireless:mac-address, err=FDT_ERR_NOTFOUND
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Unable to update property /wireless:mac-address, err=FDT_ERR_NOTFOUND

0 votes
Hi,

I just updated the ccimx6sbc to the latest Yocto 2.2-r2, the wireless and bluetooth devices are not working after that. Looking into the kernel booting, I have seen something related to the properties of the mac address:

Unable to update property /wireless:mac-address, err=FDT_ERR_NOTFOUND
Unable to update property /bluetooth:mac-address, err=FDT_ERR_NOTFOUND

I have tried to come back to 2.0-r5 which was the Yocto previously installed and did not recognize the devices either.

I there somebody having the same problem to help me out?

Thanks
Rafael
asked Aug 8, 2017 in Linux by rafaelmontano New to the Community (2 points)

Please log in or register to answer this question.

2 Answers

0 votes
looks like your board id is not set properly.U-Boot runs the bootscript in order to select the proper DTB. The bootscript uses the U-Boot environment variable $board_id

As a workaround, you can use the following:
setenv -f board_id 129
boot
If you want to make the workaround permanent, append that to the bootcmd:
setenv bootcmd "setenv -f board_id 129; ${bootcmd}"
saveenv
answered Aug 11, 2017 by LeonidM Veteran of the Digi Community (3,519 points)
0 votes
Hi,
Thanks for your answer.
Actually, I have solved the problem by reset the U-Boot environment to default values:

=> env default -a

I have performed the firmware installation process from TFTP by following the steps at Digi documentation:

=> setenv mmcdev 0
=> run partition_mmc_linux

Then I got the error after the installation is done, the module is now running but I going to test your solution as well.

/Rafael
answered Aug 17, 2017 by rafaelmontano New to the Community (2 points)
...