Home/Support/Support Forum/Digi Connect ME Ethernot port not responding, how to recover through serial port
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Digi Connect ME Ethernot port not responding, how to recover through serial port

+1 vote
Hi all,

I am new to this forum and this is my first post. I work with a lot of Digi Connect ME devices (PN: (1P) 50000878-03 T (-C variant which is a JTAG Less module) as a test engineer and not as a programmer or developer. My role is to configure them and get them ready for a specific IP address and load the company specific image.bin file to make them part of the relevant devices network. They work great for most of the times except for some times when they go wrong.

Over time I have a lot of these modules accumulated which have become non responsive through the Ethernet port. They have been sitting around to be fixed at some point but each time I have not been successful. They have lost comms through Ethernet port completely and the serial ports don't respond with the usual prompt. I have tried auto scanning the defective devices with "Device Disrecovery Utill 40002256_G.exe" provided by Digi but it never finds any of them on the net. So my only hope is the Serial port recovery.

The Serial comms port P2 (P1 never shows any comms on my Dev Board) shows the following output data spurting out all the time on some devices for example. Others show different behaviors like totally corrupted data output, no output at all or just frozen prompt.

an example output.

Loading from NVRAM... Loaded.
ÿQ ÿ@ÿ@ÿ@ÿ@ÿ@ÿQ ÿ@ÿ@ÿ@ÿ@ÿ@ÿQ ÿ@ÿ@ÿ@ÿ@ÿ@ÿQ ÿ@ÿ@ÿ@ÿ@ÿ@ÿQ ÿ@ÿ@ÿ@ÿ@ÿ@ÿQ ÿ@ÿ@ÿ@ÿ@ÿ@ÿQ ÿ@ÿ@ÿ@ÿ@ÿ@ÿQ ÿ@ÿ@ÿ@ÿ@ÿ@ÿQ ÿ@ÿ@ÿ@ÿ@ÿ@ÿQ ÿ

As the Digi Support document says;
URL: (https://forms.na1.netsuite.com/app/site/hosting/scriptlet.nl?script=457&deploy=2&compid=818164&h=5928a16f2b6f9582b799&article=how-to-recover-a-digi-connect-wi-me-9210-wi-em-and-wi-sp-jtag-less-c-module)

I have tried to write the image to the Connect ME but Nothing happens.
I have Digi Dev Board PN 30006002-01 Rev 01 which I use to load the default factory image using Tera Term Pro Serial Comms. XMODEM Send via serial port P2 on the Dev board by shorting the P12 reset pin 2 to pin 3 (GND). But no luck.

I would really appreciate if anyone help me further and put me in the right direction on how to recover these devices. I do flash other devices like FPGA's, EPROM's and various other processors in my vicinity so I'm quite competent flashing this device too but just need to know what hardware and Dev tools I need to start tackling this device?

Can I program the flash on this module directly using the GreenHills debugger?

Many thanks in advance.
asked Sep 25, 2017 in Digi Connect Cellular by Abi New to the Community (1 point)

Please log in or register to answer this question.

1 Answer

0 votes
The output you mentioned above means it is communicating over the serial port. What you can do change in Tera Term software change the baud rate to 9600 or whatever in the image file. For some reason, it actually set the baud rate to 9600. After verifying the baud rate then send the find using XMODEM and the correct baud rate.

I have just recovered few modules using the same technique.
if you see cccc as output it means the module is ready to receive the image.bin file.
answered Oct 13, 2017 by mhdazeem Community Contributor (56 points)