Home/Support/Support Forum/DOUT pin shut down on power up?

DOUT pin shut down on power up?

0 votes
I'm having an issue with some XBee-PRO 900HP S3B modules. The DOUT and DIN pins are wired directly to the Rx and Tx pins of an off the shelf product. If the XBee is powered up with the DOUT pin connected to the Rx line of the target device then the pin seems to shut down and does not initialize (it should be in the pull up state), when measured it reads 1.2V (the target device Rx pin floats at 1.2V when disconnected). However, if I power up the XBee with the DOUT line disconnected, and then manually connect the line everything works fine (line is pulled up to 3.3V and communication works).

I did get this response from the target device vendor, although I don't fully understand it. "the Rx pin is controlled by current, so to ensure the reliable signal identification, the actual control node voltage of this pin will not be lower than 1.6V." I believe the device uses a STM32 MCU.
asked Sep 27, 2017 in DigiMesh Proprietary Mesh Networking by szechyjs New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
What voltage level does the device run at?

What happens if you put a buffer circuit in?
answered Sep 27, 2017 by mvut Veteran of the Digi Community (11,298 points)
The target device runs on the same 3.3V supply.
You may need to control the VCC line of the XBee and have it power up after your processor does. Simply because that processor is trying to source current via the UART.
...