Home/Support/Support Forum/Can't connect to mixed-mode network with RCM6650W
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Can't connect to mixed-mode network with RCM6650W

+1 vote
I'm currently experiencing this issue right now using a NETGEAR R7000 running in mixed mode(WPA-PSK [TKIP] + WPA2-PSK [AES])

RCM6650W is unable to connect using TKIP or AES.. nothing seems to work. I have no problem connecting when the router network is set exclusively to AES, or no security (open).

There were issues with this last year with a hotfix implemented:

https://github.com/digidotcom/DCRabbit_10/commit/8b736d61833b1bcbcca9a133e49244f9ce464dd9

I am running DynC 10.72C, and the hotfix does exist in my version.


Update:

I have had a little bit of success connecting to my mixed mode network since creating this topic, here's the results:

What works:
Auth: WPA_PSK
Encr: TKIP

Auth: WPA_PSK
Encr: ANY

Auth: ANY
Encr: TKIP

Auth: ANY
Encr: CCMP


What doesn't work:
Auth: WPA_PSK
Encr: CCMP


If I'm going for a WPA2 [AES] connection, then using ANY + CCMP should get me there..

but it does seem a bit odd that I can't just specify WPA_PSK + CCMP to achieve the same result

Thanks
asked Oct 21, 2017 in Rabbit Software by dilbertgod New to the Community (18 points)
edited Oct 22, 2017 by dilbertgod

Please log in or register to answer this question.

1 Answer

0 votes
Are you following this warning from ifconfig() documentation?
Code:
If connecting to an access point configured for "WPA mixed mode", you must enable TKIP and CCMP (IFPARAM_WIFI_ENCR_TKIP | IFPARAM_WIFI_ENCR_CCMP) in order to use CCMP encryption. This is because mixed mode networks use TKIP for broadcast messages, and either TKIP or CCMP (depending on the client's settings) for unicast messages.
answered Oct 23, 2017 by TomCollins Veteran of the Digi Community (1,510 points)
...