Home/Support/Support Forum/HTTP GET in API Mode on Xbee LTE Cat 1

HTTP GET in API Mode on Xbee LTE Cat 1

0 votes
The example in the manual uses transparent mode to perform an HTTP GET from httpbin.org. I'm attempting to perform the same GET in API mode.

How does one specify httpbin.org using the TX IPv4 (0x20) frame type? There is only a field for destination IP and port. I tried the IP address listed in the manual for httpbin.org as well as the IP addresses provided by various online lookup services for httpbin.org. I have been getting 503s and 400s all morning. I've confirmed the service is working via web browser.

Thank you for any help.
asked Nov 1, 2017 in XBee Cellular by freddyice New to the Community (2 points)

Please log in or register to answer this question.

2 Answers

0 votes
 
Best answer
Don't forget - you just use the FQDN/DNS name and the xbee (actually the CELL MODULE) will do the IP look up based on the VZ supplies DNS info. For example, in my unit I set the DL value as "ATDLs12.remoteaware.com". I'm not using API mode, but I assume one can write strings via API mode, as things like P#/phone number is just a string of digits.

After all, the carrier (like VZ) loves to provide DNS lookup, because then they gain marketable data on your usage :-)
answered Dec 30, 2017 by Coralyn Seasoned Professional (150 points)
selected Jan 24, 2018 by freddyice
0 votes
What are you providing as an API frame?
answered Nov 1, 2017 by mvut Veteran of the Digi Community (11,302 points)
...