Home/Support/Support Forum/DIGI WR31 reboots on OpenVPN connection
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

DIGI WR31 reboots on OpenVPN connection

0 votes
I have a strange issue that hopefully someone may have come across and has a fix for...

We are Using a Windows Server running OpenVPN V2.3.18 Server

There are 2 DIGI Transports, a WR31 and a WR21. Both behave the same way.

When DIGIs have firmware 5.2.15.6 for their respective models the OpenVPN connects as clients without issue.

Upgrading to a newer firmware or even the latest 5.2.19.11 the DIGIs will on bootup establish a Celluar connection then auto reboot. Without the OpenVPN setup the DIGIs work fine with the different firmware.

Any ideas?

Many Thanks

Tim...
asked Nov 7, 2017 in Digi TransPort Cellular by 0sm0 New to the Community (4 points)

Please log in or register to answer this question.

1 Answer

0 votes
 
Best answer
Hi

There is a problem with the current firmware's

5.2.17.x
5.2.19.x

if you have certificates with more than 1024 bits the router is rebooting due to high CPU utilisation

There is a new firmware due in early December that fixes this problem

the best thing for now if you can stay on 5.2.15.x for now until this one is released or use smaller certificates

regards

James
answered Nov 8, 2017 by James.Wilson Veteran of the Digi Community (1,225 points)
selected Nov 8, 2017 by 0sm0
Thanks James

Will keep an eye out for the update

Cheers
Hi James

Was this issue resolved for OpenVPN on a windows server?

I found item 7 in the release notes

7. Corrected WR21/WR31 crash/reboot when using a 2048-bit key to connect to a Ubuntu
OpenVPN server [SAROS-2481]

OpenVPN now support 4096 bit, will a WR21 or WR31 Transport handle this?

cheers
...