Home/Support/Support Forum/Programming xbee s2c TH with groove development board by codewarrior

Programming xbee s2c TH with groove development board by codewarrior

0 votes
Hello,

I recently bought the mesh and cloud kit from DIGI.

https://eu.mouser.com/new/digi-international/digi-xbee-zigbee-mesh-kit/

https://eu.mouser.com/new/digi-international/digi-xbee-zigbee-mesh-kit/

I am able to transfer and receive packets between two xbee's using XCTU. Next I want to program the module with led blinking, LCD etc using codewarrior10.2.

I followed the bootloader tutorial initially in 'GETTING STARTED' part but while creating the .exe file it always gives the following error:

"An error occured while connecting to the interface hardware or target specified in the Launch Configuration Dialog. For this launch, you may retry/re-specify the connection with the following parameters:"

I have tried all the parameters but no success.
Any help in this regard will be appreciated.

Part no.XB24CZ7PIT-004-revJ(xbee s2c)
Same error also occurs with a xbee pro s2B version.(Part No. XBP24BZ7PIT-004J-revF

Regards,
asked Jan 3, 2018 in XBee Programmable Development by khawaja.mustafa New to the Community (3 points)
edited Jan 15, 2018 by khawaja.mustafa

Please log in or register to answer this question.

2 Answers

0 votes
 
Best answer
That is not a programmable XBee, so it doesn't have an embedded microprocessor that you can program
answered Jan 18, 2018 by DystopianFerret Veteran of the Digi Community (365 points)
selected Mar 8, 2018 by khawaja.mustafa
Thanks a lot for the response. I am now using the programmable xbee s2c surface mounted version. It is giving the same error as well.

Part no. XB24CZ7PITB003

Regards,
Did you purchase the programmable XBee kit? The kit includes a debugger, which is pretty much required doing anything with the programmable XBee: http://www.pemicro.com/products/product_viewDetails.cfm?product_id=15320168&productTab=1
0 votes
I purchased the xbee cloud kit and mesh kit but there was no debugger in it. I have now ordered one seperately. Thanks a lot for your help.
But i am having problem detecting the programmable xbee. The XCTU software detects the programmable xbee only after I reset the xbee multiple times and connect disconnect the xbee. It is kind of frustrating. Any idea about that.

Regards,
answered Jan 25, 2018 by khawaja.mustafa New to the Community (3 points)
...