Home/Support/Support Forum/Can't enable Wlan0 interface on ConnectCore i.MX6UL Starter
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Can't enable Wlan0 interface on ConnectCore i.MX6UL Starter

0 votes
Hi,



Host OS: Ubuntu 16.04 LTS x86_64
Target: ConnectCore i.MX6UL Starter
Target OS: Embedded Linux
Build Environment: Digi Embedded Yocto 2.2
Issue: Can't turn up Wlan0 interface



I'm trying to add connectivity features to the dey-image-tiny.

For that I created a dey-image-tiny.bbappend file which is the same as dey-image-tiny.bb and adding to it the following: (located here: /usr/local/dey-2.2/sources/meta-digi/meta-digi-dey/recipes-core/images/)

- On IMAGE_INSTALL I added this package:
* networkmanager

- Adding to the file IMAGE_FEATURES, that looks like:
*
IMAGE_FEATURES += " \
dey-network \
ssh-server-dropbear \
${@bb.utils.contains('MACHINE_FEATURES', 'wifi', 'dey-wireless', '', d)} \
"
*

Then compiling and have my flash images.


Once on the target, I do ifconfig and can't see the wlan0 interface:
# root@ccimx6ulstarter:~# ifconfig
eth0 Link encap:Ethernet HWaddr 00:40:9d:98:b4:ea
inet addr:10.135.9.65 Bcast:10.135.15.255 Mask:255.255.248.0
inet6 addr: fe80::240:9dff:fe98:b4ea/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2157 errors:0 dropped:0 overruns:0 frame:0
TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:212413 (207.4 KiB) TX bytes:3164 (3.0 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:2 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1
RX bytes:78 (78.0 B) TX bytes:78 (78.0 B)


I tried to up it manually, but interfaces file under /etc/network doesn't exist:
# root@ccimx6ulstarter:~# ifup wlan0
ifup: can't open '/etc/network/interfaces': No such file or directory


After I tried to configure the WiFi following this documentation link:
https://www.digi.com/resources/documentation/digidocs/90001548/reference/bsp/r_wifi_configsettings.htm%3FTocPath%3DDigi%2520Embedded%2520Yocto%7CSystem%2520development%7CCustomize%2520the%2520root%2520file%2520system%7CConfigure%2520network%2520settings%7C_____3#Set

By doing the following:
# root@ccimx6ulstarter:/# nmcli con edit wlan0

===| nmcli interactive connection editor |===

Editing existing '802-11-wireless' connection: 'wlan0'

Type 'help' or '?' for available commands.
Type 'describe [<setting>.<prop>]' for detailed property description.

You may edit the following settings: connection, 802-11-wireless (wifi), 802-11-wireless-security (wifi-sec), 802-1x, ipv4, ipv6, proxy

nmcli> set wifi.ssid AndroidAP
nmcli> set wifi-sec.key-mgmt wpa-psk
nmcli> set wifi-sec.psk xxxxxxxx
nmcli> set ipv4.method manual
nmcli> set ipv4.address 192.168.104.87/16
nmcli> set ipv4.gateway 192.168.104.10
nmcli> set ipv4.dns 8.8.8.8
nmcli> save
Connection 'wlan0' (3153f68e-dd89-3443-ab0a-88cae2fc88fc) successfully updated.
nmcli> quit

When trying to up the wlan0 interface, I have an error saying no suitable device found:
# root@ccimx6ulstarter:/# nmcli con up wlan0
Error: Connection activation failed: No suitable device found for this connection.

Below are some details provided by nmcli command:
# root@ccimx6ulstarter:/# nmcli device show
GENERAL.DEVICE: eth0
GENERAL.TYPE: ethernet
GENERAL.HWADDR: 00:40:9D:98:B4:EA
GENERAL.MTU: 1500
GENERAL.STATE: 100 (connected)
GENERAL.CONNECTION: eth0
GENERAL.CON-PATH: /org/freedesktop/NetworkManager/ActiveConnection/1
WIRED-PROPERTIES.CARRIER: on
IP4.ADDRESS[1]: 10.135.9.65/21
IP4.GATEWAY: 10.135.8.1
IP4.DNS[1]: 172.28.4.55
IP4.DNS[2]: 10.197.80.11
IP4.DNS[3]: 10.197.80.12
IP4.DOMAIN[1]: sorin.com
IP6.ADDRESS[1]: fe80::240:9dff:fe98:b4ea/64
IP6.GATEWAY: --
IP6.ROUTE[1]: dst = ff00::/8, nh = ::, mt = 256

GENERAL.DEVICE: can0
GENERAL.TYPE: can
GENERAL.HWADDR: (unknown)
GENERAL.MTU: 16
GENERAL.STATE: 10 (unmanaged)
GENERAL.CONNECTION: --
GENERAL.CON-PATH: --
IP4.GATEWAY: --
IP6.GATEWAY: --

GENERAL.DEVICE: sit0
GENERAL.TYPE: iptunnel
GENERAL.HWADDR: (unknown)
GENERAL.MTU: 1480
GENERAL.STATE: 10 (unmanaged)
GENERAL.CONNECTION: --
GENERAL.CON-PATH: --
IP4.GATEWAY: --
IP6.GATEWAY: --

GENERAL.DEVICE: lo
GENERAL.TYPE: loopback
GENERAL.HWADDR: 00:00:00:00:00:00
GENERAL.MTU: 65536
GENERAL.STATE: 10 (unmanaged)
GENERAL.CONNECTION: --
GENERAL.CON-PATH: --
IP4.ADDRESS[1]: 127.0.0.1/8
IP4.GATEWAY: --
IP6.ADDRESS[1]: ::1/128
IP6.GATEWAY: --

# root@ccimx6ulstarter:/# nmcli connection show
NAME UUID TYPE DEVICE
eth0 dce47dc1-937e-360e-bcb2-a5745f1e170b 802-3-ethernet eth0
cellular c7b0df65-2c06-3b5d-82cd-5c09be5fecf6 gsm --
eth1 7296aec4-0cf2-3172-a2a8-79bb745d5a9a 802-3-ethernet --
wlan0 3153f68e-dd89-3443-ab0a-88cae2fc88fc 802-11-wireless --


I tried also to enable wlan0 interface using wpa_supplicant:

# root@ccimx6ulstarter:/# wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant.conf
Successfully initialized wpa_supplicant
Could not read interface wlan0 flags: No such device
nl80211: Driver does not support authentication/association or connect commands
nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Could not read interface wlan0 flags: No such device
wlan0: Failed to initialize driver interface

To workaround the nl80211 driver support:

# root@ccimx6ulstarter:/# wpa_supplicant -B -i wlan0 -D wext -c etc/wpa_supplicant.conf
Successfully initialized wpa_supplicant
Could not read interface wlan0 flags: No such device
WEXT: Could not set interface 'wlan0' UP
wlan0: Failed to initialize driver interface

As shown, there is no device for wlan0

And wpa_cli can't connect to wpa_supplicant:
# root@ccimx6ulstarter:/# wpa_cli
wpa_cli v2.5
Copyright (c) 2004-2015, Jouni Malinen <j@w1.fi> and contributors

This software may be distributed under the terms of the BSD license.
See README for more details.



Interactive mode

Could not connect to wpa_supplicant: (nil) - re-trying


Finally, on my generated .manifest file I can see these related Wireless packages:
- packagegroup-dey-network ccimx6ulstarter 1.0
- packagegroup-dey-wireless ccimx6ulstarter 1.0
- wireless-regdb cortexa7hf-neon 2016.06.10
- wireless-tools cortexa7hf-neon 30.pre9
- wpa-supplicant ccimx6ulstarter 2.5
- wpa-supplicant-cli ccimx6ulstarter 2.5
- wpa-supplicant-passphrase ccimx6ulstarter 2.5


Even adding this configuration to the conf/local.conf file, then building again doesn't go through the issue:
WLAN0_MODE = "dhcp"

Do you have an idea of what's missing to enable the wlan0 interface please ?

Regards.

YC
asked Mar 1, 2018 in Linux by YounesC New to the Community (21 points)

Please log in or register to answer this question.

1 Answer

+1 vote
 
Best answer
Basically you can do a quick test by just adding the next lines to your local.conf



IMAGE_INSTALL_append = " \
bluez5 \
firmware-qualcomm-qca6564-bt \
firmware-qualcomm-qca6564-wifi \
kernel-modules \
kernel-module-qualcomm \
udev-extraconf \
wireless-tools \
wpa-supplicant \

"
answered Mar 1, 2018 by LeonidM Veteran of the Digi Community (2,822 points)
selected Mar 2, 2018 by YounesC
Hi,

Thanks a lot Leonid. It worked :)

Regards.

YC
...