Home/Support/Support Forum/ERROR: Did not find a cmdline Flattened Device Tree
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

ERROR: Did not find a cmdline Flattened Device Tree

0 votes
I'm using a DIGI ConnectCore 6UL. After updating all images, I get folowing error:

Kernel image @ 0x80800000 [ 0x000000 - 0x5236f8 ]
## Loading init Ramdisk from Legacy Image at 83800000 ...
Image Name: dey-image-recovery-initramfs-cci
Image Type: ARM Linux RAMDisk Image (gzip compressed)
Data Size: 3996765 Bytes = 3.8 MiB
Load Address: 00000000
Entry Point: 00000000
Verifying Checksum ... OK
ERROR: Did not find a cmdline Flattened Device Tree
Could not find a valid device tree

I tried to reset it to factory, but it is still the same error.

I am pretty new to linux/yocto, so I do not realy know what else I can try.

Can anybody help me?
asked May 9, 2018 in Linux by dbau New to the Community (16 points)

Please log in or register to answer this question.

1 Answer

+1 vote
Best answer
What board are you using? and what images have you flashed?
I suspect you programmed the wrong images. There is a cc6ul SBC Express (Starter), and cc6ul SBC Pro (SBC). You have to program correct images
answered May 10, 2018 by LeonidM Veteran of the Digi Community (4,457 points)
selected May 24, 2018 by dbau
Hi LeonidM,
thanks for your advice. I have a custom Board with the "DIGI Module".
I think I found the Problem:
I set the ID manually but did not changed the Devicetree-File. So it couldn't find it ?!
I haven't tried it yet.
you can manually rename dts file in boot.ubi to whatever u-boot expects to find