Home/Support/Support Forum/ConnectCore 6UL Recover
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

ConnectCore 6UL Recover

0 votes

I erased the nand memory of an CC-IMX6UL SBC PRO, while trying to update the firmware using "nand erase.chip" so i tried to recover it as described in this page


Usb debug run without issue but the boot message on serial terminal show " *** Warning - bad CRC, using default environment "

if i ignore this and use run install_linux_fw_sd command to update the firmware using SD card, it install without error but it restart in recovery mode with this message
"Error reading superblock on volume 'ubi0:recovery' errno=-22!".

if i update partitions manually using "update" it does not boot on recovery mode but still get the same message except volume linux.

Am assuming the partition table is missed-up but not sure how to fix it. And what am doing wrong to get the CRC error with USB Debug. I tried various .imx files version 2.0, 2.2 and 2.4 same error.

asked Aug 27, 2018 in Linux by hamdi.mdt.digi New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
resolved via support case/RMA
answered Sep 11, 2018 by LeonidM Veteran of the Digi Community (4,457 points)