Home/Support/Support Forum/Why does the Java Library not support Digi XBee3 Cellular LTE-M?

Why does the Java Library not support Digi XBee3 Cellular LTE-M?

0 votes
I recently purchased the Digi XBee3 Cellular LTE-M and installed the Java Library as the instructions stated. When attempting to use it to send an SMS I receive the following error:

WARNING: RXTX Version mismatch
Jar version = RXTX-2.2pre1
native lib Version = RXTX-2.2pre2
Error
com.digi.xbee.api.exceptions.XBeeException: Error reading device information: Your module seems to be Unknown and NOT Cellular. Check if you are using the appropriate device class.
at com.digi.xbee.api.AbstractXBeeDevice.readDeviceInfo(AbstractXBeeDevice.java:551)
at com.digi.xbee.api.IPDevice.readDeviceInfo(IPDevice.java:287)
at com.digi.xbee.api.CellularDevice.readDeviceInfo(CellularDevice.java:291)
at com.digi.xbee.api.XBeeDevice.open(XBeeDevice.java:368)
at com.digi.xbee.api.CellularDevice.open(CellularDevice.java:271)
at com.digi.xbee.example.MainApp.main(MainApp.java:40)

Does an update need to be made before the library can be used with the LTE M?
asked Sep 17, 2018 in XBee Cellular by SolveEtCoagula07 New to the Community (0 points)

Please log in or register to answer this question.

...