Home/Support/Support Forum/Pin Sleep on XB3-C-A2-UT / Xbee CATM1/NB-IoT

Pin Sleep on XB3-C-A2-UT / Xbee CATM1/NB-IoT

0 votes
I've been working with the Xbee CATM1 and desire to use SM=1. It seems to work fine with Verizon LTE SIM. Watching the timing, it wakes and sleep gracefully. (And yes, the 'A2' is listed as AT&T but works fine on VZ - VZ web site accepts IMEI as VZ certified. I'm very pleased to finally see modules working on both AT&T and VZ without a reflash!!!)

However, when testing an AT&T SIM (via a dual-mode by Aeris), then it only connects when SM=0. Via XCTU or my own code, if I set SM=1, then AI (assoc indicate) is always 22/23 and never 0. If I set SM=0, the Xbee connects fairly fast. The claimed carrier name is MN of "AT&T". I have the CP=0, so auto - although I did try setting to AT&T with no change.

Since I can power off the XBee, this inability to use pin sleep is not a show-stopper, but odd. Any suggestions? If I must power off the XBee, is there a command I should issue to force a graceful 'shutdown' of the cell module? I worry a bit about just powering off when ready to sleep. For example, on many telit modules one can use a "AT#SHDN\r" command to allow the cell module to do any house-keeping before power-off.
asked Sep 18, 2018 in XBee Cellular by Coralyn Seasoned Professional (150 points)

Please log in or register to answer this question.

...