Home/Support/Support Forum/Receive (RX) Packet: IPv4 - 0xB0 - Possible documentation error.

Receive (RX) Packet: IPv4 - 0xB0 - Possible documentation error.

0 votes
I am working with an Xbee LTE CAT 1 modem in API mode. Things have been going well but I think i ran across a documentation error here:

Receive (RX) Packet: IPv4 - 0xB0


On the page above it states the IP address starts at offset of "4" (offset from what?)

Upon looking at the packets I am actually getting, it looks like there are 2 bytes after the frame type of 0xB0 before the IP address. The structure appears to match what is in the documentation at that point (except that the offset in the frame is off by 2).

Can you verify/clarify the structure of the Rx IPv4 packet?
asked Dec 20, 2018 in XBee Cellular by ehughes New to the Community (3 points)

Please log in or register to answer this question.

2 Answers

0 votes
Best answer
Can you provide an example of a B0 API frame that you are seeing, and how you are interpreting the values? And can you confirm that you are using API mode 1 (ATAP 1)? If using escaped API mode (ATAP 2) then there may be additional bytes in the raw UART traffic.

Offset 4 means the IP address begins 4 bytes after the beginning of the API frame. If the frame begins with:

7E 00 21 B0 11 22 33 44 ...

Then "11 22 33 44" ( is the IP address. (The 7E delimiter is at offset "0".)
answered Dec 20, 2018 by tckr Veteran of the Digi Community (514 points)
selected Apr 22, 2019 by DigiGuy42
0 votes
Sorry for the late response. I did get this worked out. I was misreading the documentation. All is well!
answered Apr 19, 2019 by ehughes New to the Community (3 points)