Home/Support/Support Forum/Xbee3 cellular LTE-M power usage in PSM
New and improved user forum site going live on 12/6 (All users will need to reset their password when the new forum is active)

Xbee3 cellular LTE-M power usage in PSM

+1 vote
I measured the power usage of LTE-M module, it is drawing 5mA in PSM (power saving mode). Is there any way to reduce the power usage in PSM? The specification says it should draw 20 µA.

Thanks and best regards,
asked Feb 8, 2019 in XBee Cellular by jingle.yang New to the Community (2 points)

Please log in or register to answer this question.

2 Answers

0 votes
Please try disabling all unused pins, as well as disabling the Python auto-start. That should save some power.

The manual also recommends clearing bit 0 of the DO parameter: https://www.digi.com/resources/documentation/Digidocs/90002258/#Concepts/c_mode_psm.htm
answered Feb 13, 2019 by DystopianFerret Veteran of the Digi Community (368 points)
Thanks. Bit 0 of DO parameter is already cleared. Python is never used and should be disabled at default. I used the development kit to measure the current.
When modem is in PSM, is the onboard arm MCU in sleep as well? If not, that may explain the high current.
I measured the power usage in pin sleep mode as well, it is 10 µA, as suggested in the spec. But the modem is powered off in pin sleep mode.

We need clarify from Digi about the real power usage of PSM mode.
So PSM mode puts the cellular modem into low power sleep mode, but the EFR processor that runs the XBee firmware will still be awake, hence the higher current draw.

The only real way to get low power sleep mode is to use the XBee SM parameter, which puts both the cellular modem and processor to sleep.
I have used "SM" to put Xbee into sleep, but it powered the cellular modem off and the modem failed to register to network from "PSM" later.
so to be clear, we cannot use PSM mode without support of the EFR processor which uses 5mA?
0 votes
Hi Jingle,
Did you ever resolve this? I have the exact same issue right now.
It seems like we need to use pin sleep mode or something similar to enable PSM at its lowest power?
answered May 4, 2019 by tonywardlucidtron New to the Community (2 points)
reshown May 6, 2019 by rmaroun
No. When I enabled "pin sleep mode" and "PSM" together, the modem failed to register from PSM mode later. It could be a network issue, and my SIM card is from Australia Telstra. PSM does need support from network side as well.