Home/Support/Support Forum/generate pwm output in xbee using api mode

generate pwm output in xbee using api mode

0 votes
Hai ,
I tried to create pwm 1 output in xbee s2c module using api mode,first send P1 AT command with parameter of value 1 and the tried set pwm period by using AT command M1 with value 01ff.but respose is not valid command.is this command not valid.How do we can control pwm using api without i/o passing.

Below added frames which i used set pwm1,

Remote AT Command Request (API 1)

7E 00 10 17 01 00 13 A2 00 41 29 7A 6B FF FE 02 50 31 01 62

Start delimiter: 7E
Length: 00 10 (16)
Frame type: 17 (Remote AT Command Request)
Frame ID: 01 (1)
64-bit dest. address: 00 13 A2 00 41 29 7A 6B
16-bit dest. address: FF FE
Command options: 02
AT Command: 50 31 (P1)
Parameter: 01
Checksum: 62



Remote AT Command Request (API 1)

7E 00 11 17 05 00 13 A2 00 41 29 7A 6B FF FE 02 4D 31 01 FF 62

Start delimiter: 7E
Length: 00 11 (17)
Frame type: 17 (Remote AT Command Request)
Frame ID: 05 (5)
64-bit dest. address: 00 13 A2 00 41 29 7A 6B
16-bit dest. address: FF FE
Command options: 02
AT Command: 4D 31 (M1)
Parameter: 01 FF
Checksum: 62

Remote Command Response (API 1)

7E 00 0F 97 05 00 13 A2 00 41 29 7A 6B 8E 51 4D 31 02 00

Start delimiter: 7E
Length: 00 0F (15)
Frame type: 97 (Remote Command Response)
Frame ID: 05 (5)
64-bit source address: 00 13 A2 00 41 29 7A 6B
16-bit source address: 8E 51
AT Command: 4D 31 (M1)
Status: 02 (Invalid command)
Checksum: 00
asked Feb 22 in IEEE 802.15.4 by jinujose New to the Community (0 points)

Please log in or register to answer this question.

...