Home/Support/Support Forum/Mutual TLS authentication with Azure?

Mutual TLS authentication with Azure?

0 votes
I have been attempting for a while to get mutual TLS authentication to an Azure IoT Hub to work with the XBee3 Cellular modules. I have both the LTE-M module and the Cat 1 module and I have failed with both. We had some issues getting it to work in general, but now we can get messaging to the Azure IoT Hub to work with every other way except using the Xbee3 Cellular module. I'm looking for assistance in fixing the error we're seeing with the cellular module.

Using the AWS example in the MicroPython Programming Guide (located here: https://www.digi.com/resources/documentation/digidocs/90002219/default.htm#tasks/t_test_connection.htm%3FTocPath%3DUse%2520AWS%2520IoT%2520from%2520MicroPython%7C_____5), I was able to make the necessary modifications to aws_https_pc.py to send a device-to-cloud message from my computer to my Azure IoT Hub. I uploaded the server certificate, client certificate and client key to my cellular module as directed in the example. I modified the MicroPython script to match the changes I made to the Python script on my computer. When I run the MicroPython script on my computer, I get a ECONNREFUSED error on the 'w.connect' line. I've tried changing the paths for the certificates and keyfile in the ussl.wrap_socket() call (i.e., for a private key named 'priv.key', I've tried 'priv.key', 'cert/priv.key' and '/flash/cert/priv.key' for the keyfile variable). No matter what I've tried, I always get an ECONNREFUSED error on the 'w.connect' call.

Has anyone been able to get access working to an Azure IoT Hub and is able to provide guidance on what my problem may be?
asked May 15 in XBee3 Cellular by bevenson New to the Community (8 points)

Please log in or register to answer this question.