Home/Support/Support Forum/Why doesn't the i.MX28 Yocto JumpStart Kit SDK Download work?
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Why doesn't the i.MX28 Yocto JumpStart Kit SDK Download work?

0 votes
I'm trying to download the Digi Embedded Yocto JumpStart Kit SDK [0] linked from the i.MX28 support page [1]. I've tried using a web browser and a command line FTP client set to BINARY mode but each time the downloaded file ends up corrupt and doesn't match the MD5 sum. There appears to be a bunch of windows newline endings added to the download. Are the files on the server actually corrupt or am I doing something wrong here?

[0] http://ftp1.digi.com/support/developmentsoftware/40002878_G_sdkmx28_redirect.htm
[1] https://www.digi.com/support/productdetail?pid=5587
asked May 24 in Linux by user8675309 New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
The link is a redirect, not sure why is not working for you. It should redirect to the link below, does this link work for you?
ftp://ftp1.digi.com/support/digiembeddedyocto/1.6/1.6.9/sdk/40002878_G/ccardimx28js/
answered May 24 by Campbell Veteran of the Digi Community (552 points)
Yes, the file downloads but is corrupt I've tried it both through the redirect and by using an FTP client directly.  I tried downloading an older version and that works correctly so it must be corrupt on the server.
Try this link, is the 40002878_G.zip file downloaded from the source.  If this works for you, I will replace files that are in the link on the website.
ftp://ftp1.digi.com/support/images/yocto16sdk/40002878_G.zip
Yes, that one works.  Thanks!
...