Home/Support/Support Forum/Setting IO Pin Doesn't work - solved

Setting IO Pin Doesn't work - solved

0 votes
I have just gone through the process of trying to use XCTU to control an IO pin set to output on a SX 868 Digimesh XBee.

I sent the AT command in API mode:
D4 4 (= set low) and
D4 5 (=set Hi)

using the console.
It worked using the XCTU config tool but not by manually creating a packet.

I figured out the problem by looking at the data packet exchange for the config tool in the console.

The problem was that the command "D4" is ASCII and the parameter "4" needs to be hex value "04". This is not mentioned in the manual. If it is, I can't find it.

The same is likely to be true for similar commands.

Dazz
asked Jul 16 in RF Solutions and XBee by dazz New to the Community (12 points)

Please log in or register to answer this question.

1 Answer

0 votes
The answer is in the manual under the section :
"Send AT Commands"
but I had ignored this section because this is related to command mode, which I am not using.

The AT format is specified in that section.
answered Jul 16 by dazz New to the Community (12 points)
...