Home/Support/Support Forum/pip is no longer supporting Python 2.6.1, Can I upload python 3.7.4 script into the Digi WR31?
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

pip is no longer supporting Python 2.6.1, Can I upload python 3.7.4 script into the Digi WR31?

0 votes
I'm trying to develop a code that can disable and enable an Ethernet port on Digi WR31. For that I need to import some python packages. When attempting to install pip on my machine for Python 2.6.1, the system responded back with following message:

C:\Users\agaw\Downloads>python get-pip.py
Traceback (most recent call last):
File "get-pip.py", line 22308, in <module>
main()
File "get-pip.py", line 197, in main
bootstrap(tmpdir=tmpdir)
File "get-pip.py", line 82, in bootstrap
import pip._internal
File "c:\users\agaw\appdata\local\temp\tmpqj4l9q\pip.zip\pip\_internal\__init__.py", line 19, in <module>
File "c:\users\agaw\appdata\local\temp\tmpqj4l9q\pip.zip\pip\_vendor\urllib3\__init__.py", line 7, in <module>
File "c:\users\agaw\appdata\local\temp\tmpqj4l9q\pip.zip\pip\_vendor\urllib3\connectionpool.py", line 93
_blocking_errnos = {errno.EAGAIN, errno.EWOULDBLOCK}
^
SyntaxError: invalid syntax

Then I downloaded pip for Python 2.6.1 and got the following message:

C:\Users\agaw\Downloads>python get-pip.py
DEPRECATION: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of pip will drop support for Python 2.6
Collecting pip<10
c:\users\agaw\appdata\local\temp\tmpungtw7\pip.zip\pip\_vendor\urllib3\util\ssl_.py:339: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
c:\users\agaw\appdata\local\temp\tmpungtw7\pip.zip\pip\_vendor\urllib3\util\ssl_.py:137: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
Retrying (Retry(total=4, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '_ssl.c:480: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version'),)': /simple/pip/
c:\users\agaw\appdata\local\temp\tmpungtw7\pip.zip\pip\_vendor\urllib3\util\ssl_.py:137: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
Retrying (Retry(total=3, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '_ssl.c:480: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version'),)': /simple/pip/
c:\users\agaw\appdata\local\temp\tmpungtw7\pip.zip\pip\_vendor\urllib3\util\ssl_.py:137: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
Retrying (Retry(total=2, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '_ssl.c:480: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version'),)': /simple/pip/
c:\users\agaw\appdata\local\temp\tmpungtw7\pip.zip\pip\_vendor\urllib3\util\ssl_.py:137: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
Retrying (Retry(total=1, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '_ssl.c:480: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version'),)': /simple/pip/
c:\users\agaw\appdata\local\temp\tmpungtw7\pip.zip\pip\_vendor\urllib3\util\ssl_.py:137: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
Retrying (Retry(total=0, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError(SSLError(1, '_ssl.c:480: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version'),)': /simple/pip/
c:\users\agaw\appdata\local\temp\tmpungtw7\pip.zip\pip\_vendor\urllib3\util\ssl_.py:137: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
Could not fetch URL https://pypi.python.org/simple/pip/: There was a problem confirming the ssl certificate: HTTPSConnectionPool(host='pypi.python.org', port=443): Max retries exceeded with url: /simple/pip/ (Caused by SSLError(SSLError(1, '_ssl.c:480: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version'),)) - skipping
Could not find a version that satisfies the requirement pip<10 (from versions: )
No matching distribution found for pip<10

C:\Users\agaw\Downloads>pip install pandas
Requirement already satisfied: pandas in c:\program files\python37\lib\site-packages (0.24.2)
Requirement already satisfied: python-dateutil>=2.5.0 in c:\program files\python37\lib\site-packages (from pandas) (2.8.0)
Requirement already satisfied: numpy>=1.12.0 in c:\program files\python37\lib\site-packages (from pandas) (1.16.4)
Requirement already satisfied: pytz>=2011k in c:\program files\python37\lib\site-packages (from pandas) (2019.1)
Requirement already satisfied: six>=1.5 in c:\program files\python37\lib\site-packages (from python-dateutil>=2.5.0->pandas) (1.12.0)

C:\Users\agaw\Downloads>py -2 -m pip install pandas
C:\Python26\python.exe: No module named pip

Thank you
asked Aug 1 in 3rd Party Python and API development in other Languages by Alaa New to the Community (0 points)

Please log in or register to answer this question.

...