Home/Support/Support Forum/Digi Connect ME - trouble in upgrade firmware
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Digi Connect ME - trouble in upgrade firmware

0 votes
First of all hallo to everyone.
Second: I'm an idiot.

Try to explain:
I'm a pharmacist, I live in Italy and I have as all, a green led cross outside of my pharmacy.
The Led cross came from Ible an italian manifacturer.
The cross came also with a software and a module that connect the cross to LAN.

Everything was working well, and last month I've decided that I need to update the digiconnectme firmware.
I downloaded the ConnectPort X2 / Connect ME 4meg / N2S-170 POST firmware and I flashed via the web interface.

After that everything stopped to work. The led blinks but I can't connect the cross anymore.
So I tried to search some "recovery method" on the web but I've realized that I did a big mistake.

The problem should end contacting Ible and sending me a new module... .but...
Ible was not in business anymore, they declared bankruptcy in June.

So I'm here only to ask a simple question.
Is there any way to get the module back to work? (or anyone that can do it for me?)

thanks a lot for your patience and reply

Marco

here's you can find the picture of the board.

https://ibb.co/Chnm4g8
asked Aug 26 in Plug N' Play by farmacia New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
Based on the module's S/N this is DC-ME-01T-S a Digi Connect ME 2Mb module with plug-and-play firmware:
The best firmware for it is here:
ftp://ftp1.digi.com/support/firmware/93000942_K4.txt


But you say you did not flash the firmware, but you have updated POST from a 4Mb image into a 2Mb module, which would explain a brick. Correct POST is:
Digi Connect 2MB ME POST Firmware
http://ftp1.digi.com/support/firmware/82000867_H.bin

Anyways I don't think you can recover this module without development board/access to the serial port.
-S plug-and-play recovery instructions are here:
ftp://ftp1.digi.com/support/images/connect/intkit/docs/Connect_Mfg-DiagsMode.pdf
But agin they assume that the module is plugged into development board and rely on Serial port presence.

Your best bet is to buy a new module and find someone who can desolder the old one and solder the new one:
https://www.digi.com/products/models/dc-me-01t-s
answered Aug 28 by LeonidM Veteran of the Digi Community (3,129 points)
edited Aug 28 by LeonidM
...