Home/Support/Support Forum/Modbus TCP through WR11
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Modbus TCP through WR11

0 votes
I have been trying to connect a SCADA system to an Automation Direct PLC through a WR11 cellular modem using Modbus TCP. This same physical system was used previously with an OPC server that used a native protocol to connect to the PLC without issues. I had a port forwarded using the native PLC programming port (28784) and have now added a port forward using the default Modbus TCP port (502). What is interesting is if I initiate a connection from my local subnet to the PLC using the 28784 connection, then the Modbus connection works. It will stay working as long as I am connecting through 28784. If I stop using this connection method then the Modbus connection will work for exactly 40 minutes before dropping out. I suspect that it has nothing to do with the ports, but more the method. I have spent an unbelievable amount of time trying to make this work. Any thoughts would be appreciated.
asked Sep 12 in Digi TransPort Cellular by scwiebe New to the Community (0 points)

Please log in or register to answer this question.

3 Answers

0 votes
Please post full debug.txt from your Digi router

http://ftp1.digi.com/support/documentation/QN_024_Extracting%20the%20debug.txt%20file%20from%20a%20Digi%20TransPort%20or%20Sarian%20router.pdf
answered 1 day ago by shatman Community Contributor (63 points)
0 votes
This could be a number of different issues that aren't related to the WR11.
What product are you using as your IO server into your SCADA system?
What SCADA/HMI software?
What AD PLC are you using?
answered 1 day ago by willpoll New to the Community (4 points)
Scada is Wonderware system platform version 14.
PLC is a DL06.
I am using the built Modbus TCP driver within Wonderware, but have tested with various other Modbus TCP clients and all give the same results.  I have given up on this issue for now and purchased a KEPware OPC server.  It would still be interesting to know.
Thanks.
So a DL06 has no Ethernet port, right?

Are you using a Serial to Ethernet gateway? Does it have any status lights you can monitor to determine if the Modbus polls are making through the WR11 to the gateway.

Are you aware of the Koyo OI Server for Wonderware?

https://industrial-software.com/training-support/downloads/koyo-oi-server/

This might give you more flexibility than Modbus and will use port 28784 vs 502.
0 votes
Modbus devices communicate using a master-slave (client-server)
technique in which only one device (the master/client) can initiate
transactions (called queries). The other devices (slaves/servers) respond
by supplying the requested data to the master, or by taking the action
requested in the query. A slave is any peripheral device (I/O transducer,
valve, network drive, or other measuring device) which processes
information and sends its output to the master using Modbus. The Acromag
I/O Modules form slave/server devices, while a typical master device is a
host computer running appropriate application software. Other devices may
function as both clients (masters) and servers (slaves).
answered 59 minutes ago by smithclarkson1 New to the Community (2 points)
...