Home/Support/Support Forum/UART/ XBEE 802.15.4 Latency

UART/ XBEE 802.15.4 Latency

0 votes
What is the maximum latency between uart message arriving in XBee module and sending into the radio ?
Same question for receiving ?
I made a scope analysis which show that we sometimes more than 40 ms.
I'm using XBEE module (802.15.4) Fw version 2006.
Thanks for your feedback.
asked Nov 25 in RF Solutions and XBee by francoiscadden New to the Community (3 points)

Please log in or register to answer this question.

4 Answers

0 votes
That looks about right.

https://www.digi.com/support/knowledge-base/timing-comparison-for-data-transfer-by-product
answered Nov 25 by mvut Veteran of the Digi Community (11,450 points)
Precision on Xbee latency
0 votes
This delay is very normal with XBee modules. Infact, I believe this transmission setup wouldn't be encountering any retries. Otherwise I would expect this delay to go up by few tens of milliseconds more than current value.
answered Nov 26 by asgm Veteran of the Digi Community (1,421 points)
0 votes
Download the Office setup file on www.office.com/setup and install it on your system. Enter the product key on office.com/setup to activate your product.

norton.com/setup
office.com/setup
norton.com/setup
mcafee.com/activate
norton.com/setup
answered Dec 2 by blairlennon2019 New to the Community (1 point)
0 votes
Thanks,
Data are given for S1 model. We use XB3-24Z8UT module.
Are the latency given are still available?
Other question, what's the maximum payload per transfer ? 84 bytes ? 94 bytes ? 104 bytes ?
The next link gives 94 is it still true for our device ?
https://www.digi.com/support/knowledge-base/maximum-payload-size-for-digi-rf-products?q=ConnectPort+TS+8+MEI&l=en_US&fs=RelatedArticle
answered Dec 2 by francoiscadden New to the Community (3 points)
...