Home/Support/Support Forum/Error in Digi XBee ANSI C Library

Error in Digi XBee ANSI C Library

0 votes
Hi,

I am using Digi XBee SX RF Module Dev Kit (digimesh):
https://www.digi.com/products/models/xk9x-dms-0


I connected digimesh devkit to my Linux PC. I also changed baudrate to 115200 for my XBee using ATBD command. I can use minicom with 115200 baudrate to send AT command (e.g. ATSL etc) and receive response from it.

I compiled the c lib:
https://github.com/digidotcom/xbee_ansic_library

There is a transparent_client sample app. I run it with "./transparent_client /dev/ttyUSB2".
How ever, it got an error:
Waiting for driver to query the XBee device...
Error -110 waiting for query to complete.
XBee on /dev/ttyUSB2: HV=0x0 VR=0x0 IEEE=00-00-00-00-00-00 net=0x0000

When I run "atsl" from transparent_client, it times out:
atsl
ATSL (timed out)
asked Mar 10 in DigiMesh Proprietary Mesh Networking by shuodo New to the Community (1 point)

Please log in or register to answer this question.

1 Answer

0 votes
 
Best answer
Shuodo,

Are you able to monitor the TTY USB port and see if the +++ is occurring or not? The other question is what version of the library are you using?

Digi Support
answered Mar 13 by mvut Veteran of the Digi Community (11,963 points)
selected Mar 13 by shuodo
Hi,

I am good now. My Xbee was not in API mode before. After I set ATAP=1, it works.

Thanks,
...