Home/Support/Support Forum/My end node can only join the coordinator if the Extended PAN ID is set to 2015

My end node can only join the coordinator if the Extended PAN ID is set to 2015

0 votes
Why my end node only connects if my coordinator is set to the Extended Pan ID 2015?

The configuration of the End Node Extended Pan ID is set to 0, i.e., it will join any network that is open to be joined.

If I set the coordinator the Extended Pan ID to 2010, check the OP, it's set 2010. Then I restart the End node, it never connects. I can see through two ways it doesn't connect, from the AI parameter (0x27) and from the Serial Monitor, if I try to send a message it gives me the error: 22 (Not joined to network)

If I change the coordinator Extended Pan ID to 2015, check the OP, it's set to 2015. Then I restart the End node, it connects right away. I can see through two ways it connects, from the AI parameter (0x0) and from the Serial Monitor, Modem Status 02 (Device associated).

Anybody know why this is happening? What if I have to set two different XBee networks with different Extended PAN IDs?

- The devices are in the last firmware 1009
- Both devices are Digi XBee Zigbee 3.0
asked Apr 1 in XBee3 ZigBee by dansbrazil New to the Community (1 point)

Please log in or register to answer this question.

1 Answer

0 votes
Dansbrazil,


Do you have any other Zigbee networks in the area?

Try restoring both to defaults and then set the coordinator CE to 1. Leave it at 0 for the PAN ID and then power up the end node also being restored to defaults.

Digi support
answered Apr 1 by mvut Veteran of the Digi Community (12,309 points)
No Zigbee in the area.
After restoring both modules to the default, it worked! There was probably some problem in the firmware of the end node.
Thank you
...