Home/Support/Support Forum/Series 2 Join Notification

Series 2 Join Notification

0 votes
Using firmware version 1320 for the end device and 1120 for the coordinator, I have set JN to 1, AO to 0 for both.

Taking DIO0 momentarily low or issuing "ND" command from the coordinator gets the Node Identification frame as I am expecting.

However, resetting the end device, or powering down/up does NOT prompt it to sent a correct response on joining the PAN.

Have I missed something or is the manual in error?

Matt
asked Jan 25, 2008 in ZigBee PRO Featureset (and legacy ZNet 2.5) by mdknight New to the Community (3 points)

Please log in or register to answer this question.

4 Answers

0 votes
The firmware version that you have is giving the behavior that I would expect for the Join Indicator features (section 5.4 in the 1x2x manual). I would not expect a /RESET or power OFF/ON to send a Join Verification.

The behavior that I would expect from the 1x4x firmware version would be to send a Join Verification on a /RESET or power OFF/ON. The 1x4x firmware has not yet been released but should be available for download from our site soon.
answered Jan 25, 2008 by travish New to the Community (19 points)
0 votes
It was section 5.4 in the manual that led me to think I ought to receive an ND response packet when the device joined the PAN.

But if it's coming in the next release that's great.
Look forward to it.

Thanks
Matt
answered Jan 25, 2008 by mdknight New to the Community (3 points)
0 votes
Yes when the device JOINS the PAN it does send a Join Notification but when you /RESET or power OFF/ON the device it does not re-join the network. It simply stays joined to the network it was previously joined to (again this will change with the addition of the JV - Join Verification parameter in 1x4x).
answered Jan 25, 2008 by travish New to the Community (19 points)
0 votes
Ah! Got it.

Thanks for the clarification.
I'm being a bit dense today.

Matt
answered Jan 25, 2008 by mdknight New to the Community (3 points)
...