Home/Support/Support Forum/Xbee S2C Zigbee freezes and module stop receiving ADC Samples

Xbee S2C Zigbee freezes and module stop receiving ADC Samples

0 votes
I'm using modules Xbee S2C PRO Zigbee to make a wireless sensor network, it is already with a newest firmware version (4061). The end-device module is measuring temperature through ADC Reads. It has IR selected on a great value 10s, for the module send to the coordinator just one time. In the network I have also a router and one coordinator that is conected to a computer, that reads data through serial communication.
The parameters of all modules are the same:
ST=FA (250ms)
SP=AF0 (28s) is the maximum
SO=2 on the end device (is not using SO=4, because Digi's Technical support recommended SO=2, due to doesn't happen data loss.
The module seems to work great at the beginning, but after some time, just receiving the data samples, the communication looks unstable.
Some periods it results on more than one hour without receiving any messages, but after that, the end device sends a node identification fram and starts all again.
This is a critical application, I can't loose 1 hour of data.
I am already in contact to support of Digi, but due to the critical time I decided to write a post here too.
Does anyone had some problem like this?
asked Apr 22, 2020 in ZigBee PRO Featureset (and legacy ZNet 2.5) by danielaid New to the Community (2 points)

Please log in or register to answer this question.

2 Answers

+1 vote

Try increasing your ST time frame and decrease your sleep time on the end device.

Digi Support
answered Apr 23, 2020 by mvut Veteran of the Digi Community (15,413 points)
0 votes
Hi, I was tryng to use the minimum ST possible to save battery. I just need one sample every 5 minutes, so if I decrease my sleep time I will use even more battery.
But I'll try out with these new settings, any new idea is great!
answered Apr 23, 2020 by danielaid New to the Community (2 points)
Changing the SC parameter? I left the default because this way will scan all the channels, instead of choosing anyone, I read this article https://www.digi.com/resources/documentation/digidocs/90001537/references/r_channels_zigbee.htm is that better if I choose one channel high?

I am not suggesting to choose a specific channel but to eliminate the channel you are using leaving the rest to choose.  The Coordinator may have selecting it but it also may not have been having the interference at the time where you know know you probably have.

Digi Support
I see that network was using channel 24, 0x18. So I put SC mask of 5FFF in all the modules, after that from the coordinator I use ATNR1, and the devices were disassocieted and then the coordinator started. It wnt to another channel 0x12, and I lost the communication with my modules. I Try go back to 7FFF and reset the network, but still can't reach them, when I scan the network thy aren't there. The part it gets complicated it's because I was testing remotely, so I can't pick every device and reset them. Is there anyway to recover the contact? The PANID was manteined.

The ATNR1 is a global network reset. If there is another network in range and you were using the 0 value for the PAN ID, they could have gone to that network.

Digi Support
I can't assure that isn't a network around there, but my PAN ID is 4321, kind difficult to be the same. Anway, I'm going to go in person to check it in loco.