Home/Support/Support Forum/XBee 3 modules no longer recognized by XCTU
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

XBee 3 modules no longer recognized by XCTU

0 votes
I have two XBee3 SMT Grove Development boards. When I run XCTU, they don't show up. I suspect that they are running MicroPython flash programs and won't connect to the PC. Is there a 'master reset' or some other way to stop them?

Module 1: In XCTU, when I selected the 'Device not found?' link, I tried all the options, including the Recovery Tool. Recovery Tool appeared to work. It uploaded the firmware, etc but it still isn't recognized by XCTU.

Module 2: In XCTU, it said Could not find any device in port COM13 > Error initializing XBee device parameters > Port already in use by other applications. (There are no other applications, except maybe the microPython one running on the development board. I changed the serial library to Alternative, then I tried the Recovery Tool but got a message stating "Error opening the serial connection. > Port name - COM13; Method name - openPort(); Exception type - Port Busy.

I'm using a Windows 10 computer, XCTU 6.5.1, my development board's firmware has been updated in the last month, the modules have connected to XCTU in the past, I've been working my way through the Digi MicroPython Programming Guide.
asked Jun 4 in USB by tw.lewis New to the Community (3 points)

Please log in or register to answer this question.

3 Answers

0 votes
 
Best answer
SOLUTION #1: Use the Serial Console in XCTU, press reset and enter +++ to get the modules attention. After you get OK, type AT FS FORMAT CONFIRM to format the file system. If this doesn't work...

SOLUTION #2: The File System is not preserved across updates, so connect the module to XCTU. Select the UPDATE icon, choice an older firmware version and update to the older version. After the update is complete, you can run it again update to the newer version.
answered Jun 25 by tw.lewis New to the Community (3 points)
edited Jun 26 by tw.lewis
0 votes
TW Lewis,

I would suggest using the Serial Console mode in XCTU's Tools menu, then trying to enter command mode manually by doing a +++. If you get an Ok, you can then issue the ATPS0, with a Carriage return. Then an ATWR followed by a Carriage return. That will turn off the Python Auto Start and write it to flash. If you then do an ATCN <CR> that will exit command mode.

Digi Support
answered Jun 4 by mvut Veteran of the Digi Community (13,374 points)
0 votes
Module 2: I deleted the COM port and then I was able to run XBee Recovery and everything appears back to normal. Google "How to delete COM ports in use" and you'll probably find the instructions I used.

However...

Module 1: I was able to connect to the Serial Console but when I typed +++ I didn't get a response.

What else can I try?
answered Jun 5 by tw.lewis New to the Community (3 points)
Try the XBee recovery on the 2nd module.
As per the original post, the Recovery Tool goes through the paces but the module is still not recognized after the recovery process.
Please contact Digi Support by sending an email to tech.support@digi.com
...