Home/Support/Support Forum/XBee S2C ZigBee: pins 2,3 and 17 won't act as DIO

XBee S2C ZigBee: pins 2,3 and 17 won't act as DIO

0 votes
XBee S2C ZigBee: pins 2,3 and 17 won't act as DIO. I have been working on a project involving XBee S2C... currently have a coordinator module and 2 router modules communicating.. a GUI started... I have sunk many many hours into the project making progress:).

I am successfully configuring and manipulating 12 of the 15 available DIO BUT not pins 2,3, and 17. They don't seem to care what I set them to in XCTU or in my programming code. Anyone know any reasons for these pins not working as DIO (The datasheet says they should be DIO since there are 15 total.) Both router modules in the network are showing pin 2,3, and 17 with the same stubbornness. I have troubleshooted a good deal (multimeter) and changing configuration in XCTU as well as in code.

I need 14 DIO for my project, per XBee router module, and also I'm not sure that XBeeS2C supports port expanders(?)...so these pesky stubborn pins 2,3,and17 are important to my project.

Anyways, anyone know why pins 2,3, and 17 aren't cooperating as DIO?

Thank you! :)
asked Jun 15 in RF Solutions and XBee by edunn106 New to the Community (24 points)

Please log in or register to answer this question.

1 Answer

0 votes
No, the module does not support Port extenders.

Pins 2 and 3 are used as the UART. So if they are connected to a PC, they will be used as this unless you set P3 and P4 other values then 1, they will function as the UART.
answered Jun 16 by mvut Veteran of the Digi Community (13,333 points)
...