Home/Support/Support Forum/could not determine operating mode
New and improved user forum site going live on 12/6 (All users will need to reset their password when the new forum is active)

could not determine operating mode

0 votes
I cannot find a solution to this problem. My XBee 900HP digimesh was working perfectly in AP (1) mode (as coordinator). Now it no longer works, my python3 code has not changed. If I connect to XCTU it appears to be working and receives data from the routers as expected.

I pulled a snip of the code that used to work. I have it running on a Raspberry PI 3. Again everything was working.

import serial
from digi.xbee.devices import XbeeDevice
device = XBeeDevice("/dev/ttyS0", 9600)

Once the open line is executed I get the following error:

Traceback (most recent call last):
File "<pyshell>", line 1, in <module>
File "/home/pi/.local/lib/python3.7/site-packages/digi/x
bee/devices.py", line 2043, in open
File "/home/pi/.local/lib/python3.7/site-packages/digi/x
bee/devices.py", line 2059, in _do_open
Raise InvalidOperatingModeException(message="Could not
determine operating mode")
digi.xbee.exception.InvalidOeratingModeException: Could n
ot determine operating mode

...Again, this used to work and I am completely baffled.

Any help would be greatly appreciated. If I need to supply more detail please let me know and I
can send screen shots and pictures.

Thank you,
asked Jun 22, 2020 in XBee3 DigiMesh by wrwygal New to the Community (0 points)

Please log in or register to answer this question.

3 Answers

0 votes

That is not something that would be answered on this forum but on a forum for the processor and its related code.
answered Jun 22, 2020 by mvut Veteran of the Digi Community (15,515 points)
0 votes
my python3 code has now not changed. If I join to XCTU it seems to be working and receives facts from the routers as expected.
answered Jun 24, 2020 by Bears New to the Community (3 points)
0 votes
Hello wrwygal,
I 've got the same problem. The same error with an unchanged code that worked before. I tried to change the raspberry without success. Did you finally found a solution ?
Thank you
answered Jul 14, 2021 by drmad51 New to the Community (1 point)