Home/Support/Support Forum/XBXC3 update to 1140F / 11410 failing

XBXC3 update to 1140F / 11410 failing

0 votes
I have a cellular XBee (XBXC3 XBC LTE-M/NB-IoT Global) which I am trying to update to current firmware. When received, the device was on 1140B and I can update it to 1140C without issue.

However, whenever I try to update to 1140F (the transition version to 11410) it gets through the update process, waits for a reset, tells me that it has succeeded and that I should add the XBee, and then is undetected.
When recovering the XBee back to 1140B or 1140C XCTU details show the bootloader is missing.

I am using a USB breakout with mapped flow control pins.

Any ideas on how to get my XBee to 11410, or is it forever stuck at 1140C or older?
asked Jul 20 in XBee Cellular by balloonz New to the Community (0 points)

Please log in or register to answer this question.

2 Answers

0 votes
You need to use an XBIB-CU-TH board to perform the update with. Also once you update to the 1140F firmware, there is no going back in versions. You can only load on a newer version after the 1140F has been installed.
answered Jul 20 by mvut Veteran of the Digi Community (12,786 points)
I am confused as to what capabilities the XBIB provides that a separate board with mapped flow control pins does not. (In particular, the XBee Sparkfun USB Dongle) Is there some reason XCTU reports that the update succeeds even when it fails? Just a little bit hesitant to buy the dev board since this update is really the only thing I would need it to do.

I am ok with not being able to load old firmware.
First off, it provides the proper power requirements for the cellular modules. Second, it provides access to the USB direct pins which are needed for updating the Cellular component.  Both of which the Sparkfun boards do not.
Again, this setup is being used only to upgrade firmware. I don't think power would be a problem for programming, the MIC5219 regulator is rated to 500mA which should be more than enough to write firmware as long as I don't try to transmit at the same time.

Which pins are you referring to? The Sparkfun board does provide the FTDI chip with DTR/CTS/RTS, are there others that are needed?
0 votes
In addition to what mvut says, you should make sure you are using the latest version of the XCTU tool. Older versions of XCTU will error out or behave strangely when updating to 1140F/11410. ( https://ftp1.digi.com/support/firmware/release_notes/xbee3_cell_ltem_att/93001302_H.pdf )

You should be able to use the XBee Recovery tool in XCTU to 'recover' to 11410 successfully.
answered Jul 21 by tckr Veteran of the Digi Community (368 points)
I had been updated, but I've just clean installed the software. In the install it indicates the cellular XBee's need special drivers to function, but the link is dead. Any idea what those drivers would be? My guess would be for the SARA-R410M but I'm not sure.
It will be the U-Blox driver at the link above.
...