Home/Support/Support Forum/SO (sleep options) Confusion in Point to Multi-point P2MP Network

SO (sleep options) Confusion in Point to Multi-point P2MP Network

0 votes
XBee SX (non PRO version)

Hello, I'm back! Hopefully it's my last question. I have P2MP net work, an indirect msg coordinator and an indirect msg poller.

On the end device (poller), if I set SO = 100, it will stay awake for over 100ms every wake period. If I set SO = 0, the radio stays on long enough ONLY to send a sample and receive an ACK (typically 10-15ms) even though I have ST = 35ms. I measured these times on the sleep status output pin using my oscilloscope. The manual doesn't describe SO options for asynchronous network in enough detail.

I read that ST time is the amount of time the radio will stay awake after receiving RF or serial data. I also read SO = 100 (bit 8) forces the radio to stay awake for ST amount of time.

Neither of these descriptions explains why SO == 100 keeps the radio on for over 100ms and SO == 0 only keeps the radio on for the time it needs to transmit data. My ST time for all tests stays at 35ms

End device (poller) settings:

PL = 1
CE = 4
DH = 0013A200
DL = 41ABDB52
TO = 40
AP = 1
DO = 3
D1 = 3
D2 = 2
IR = 3E8 (1000ms)
SP = 2BC (7000ms)
ST = 23 (35ms)

Does anybody know whats happening? Can I used asynchronous cyclic sleeping pollers with SO = 0?

Thanks!
asked Jul 27 in Multipoint Proprietary by Jamespie New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
https://www.digi.com/resources/documentation/Digidocs/90001477/Default.htm#reference/r_cmd_so.htm%3FTocPath%3DAT%2520commands%7CSleep%2520commands%7C_____2
answered Jul 27 by mvut Veteran of the Digi Community (12,834 points)
...