Home/Support/Support Forum/Serial port fail with ConnectCore 6UL & Yocto with systemd
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Serial port fail with ConnectCore 6UL & Yocto with systemd

0 votes
I was able to read and write through serial with an C application before.

But after I change sysvinit to systemd the serial port doesn't work anymore (ttymxc1).

The console serial port (ttymxc4) works ok.

When ttymxc1 is opened by the app, at the system console trows:

20ec000.sdma: sdma firmware not ready!
imx-uart 21e8000.serial: Prepare for the RX slave dma failed!

Also the bluetooth init fails because seems to work only with sysvinit:

[FAILED] Failed to start Initialization of the bluetooth chip.
See 'systemctl status bluetooth-init.service' for details.

Jul 30 06:21:27 ccimx6ulsbc bluetooth-init[656]: /etc/bluetooth-init: .: line 91: can't open '/etc/init.d/functions': No such file or directory

Anyone could give any clues to make the serial work again?

I need systemd to control the start and fail restart of the app.
asked Jul 30, 2020 in Embedded Devices by TCRobotics New to the Community (8 points)
Have you tried this with stock DEY-3.0 images?
No, tried with DEY 2.6

The new release has changes in this topic??

If yes I have now an excuse to upgrade

Please log in or register to answer this question.