Home/Support/Support Forum/XCTU failed at start
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

XCTU failed at start

0 votes
Hi everyone,
When i try to start X-CTU, a pop up box with error appear showing the .log path file.
below the text:

!SESSION 2020-08-04 12:14:06.121
eclipse.buildId=unknown
java.version=1.8.0_131
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=es_ES
Framework arguments: -clearPersistedState
Command-line arguments: -os win32 -ws win32 -arch x86 -clearPersistedState

!ENTRY org.eclipse.ui 2 2 2020-08-04 12:14:45.972
!MESSAGE Perspective with name 'Configuration perspective' and id 'com.digi.xctung.perspectives.configurationPerspective' has been made into a local copy

!ENTRY org.eclipse.ui 2 2 2020-08-04 12:14:46.341
!MESSAGE Invalid preference category path: org.eclipse.equinox.internal.p2.ui.sdk.ProvisioningPreferencePage (bundle: org.eclipse.equinox.p2.ui.sdk.scheduler, page: org.eclipse.equinox.internal.p2.ui.sdk.scheduler.AutomaticUpdatesPreferencePage)

!ENTRY org.eclipse.osgi 4 0 2020-08-04 12:14:48.233
!MESSAGE Application error
!STACK 1
org.eclipse.swt.SWTError: No more handles
at org.eclipse.swt.SWT.error(SWT.java:4559)
at org.eclipse.swt.SWT.error(SWT.java:4448)
at org.eclipse.swt.SWT.error(SWT.java:4419)
at org.eclipse.swt.widgets.Widget.error(Widget.java:482)
at org.eclipse.swt.widgets.TaskBar.createHandle(TaskBar.java:103)
at org.eclipse.swt.widgets.TaskBar.<init>(TaskBar.java:96)
at org.eclipse.swt.widgets.Display.getSystemTaskBar(Display.java:2605)
at org.eclipse.ui.internal.StandardTrim.createProgressBar(StandardTrim.java:72)
at org.eclipse.................

!ENTRY org.eclipse.ui.workbench 4 2 2020-08-04 12:14:48.278
!MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.ui.workbench".
!STACK 0
org.eclipse.swt.SWTException: Widget is disposed
at org.eclipse.swt.SWT.error(SWT.java:4533)
at org.eclipse.swt.SWT.error(SWT.java:4448)
at org.eclipse.swt.SWT.error(SWT.java:4419)
at org.eclipse.swt.widgets.Display.error(Display.java:1262)
at org.eclipse.swt.widgets.Display.checkDevice(Display.java:747)
at org.eclipse.swt.widgets.Display.getActiveShell(Display.java:1481)
at org.eclipse.ui.internal.services.WorkbenchSourceProvider.getActiveWindow(WorkbenchSourceProvider.java:426)
at org.eclipse.ui.internal.services.WorkbenchSourceProvider.updateActivePart(WorkbenchSourceProvider.java:458)
........................
asked Aug 4, 2020 in Console Servers by XENPAUL New to the Community (3 points)

Please log in or register to answer this question.

2 Answers

0 votes
Hello XENPAUL,

I'm afraid we will need more information to find a way to address your issue.

- What version of XCTU are you trying to start?
- What Windows version do you use?
- Would it be possible to get the full .log file of your XCTU installation? It is located at <xctu_installation_path>/workspace/.metadata/.log
- Have you tried to perform a fresh installation (from scratch) of the latest version of XCTU? Download link: https://www.digi.com/products/embedded-systems/digi-xbee/digi-xbee-tools/xctu#productsupport-utilities

Regards!
answered Aug 5, 2020 by diegoe New to the Community (44 points)
0 votes
Hi Diegoe, Thanks for your help:
- The last one for windows posted (6.5.1 x86/x64)
- Windows 7 PRO SP1 32b
- I cannot attach the file and its size is too large to transcribe it in full here.
I add that after the installation, the soft started only once but after closing it, it could never again.
I have noticed that the previous version: 6.3.8 Build ID: 20170518-2, was not automatically uninstalled and is still functional.

Thanks again
answered Aug 6, 2020 by XENPAUL New to the Community (3 points)
Diegoe,
The issue was solved executing it like administrator.
Regards
Xen
...