Home/Support/Support Forum/Xbee syncronise sleep issue causing significantly draning of battery

Xbee syncronise sleep issue causing significantly draning of battery

0 votes
I'm currently working with digi xbee3 micro module and kept 3 devices(A,B,C).
A - coordinator
B - end device 1
C - end device 2
For device B and C configured with default wake up time 2 seconds and synchronize cyclic sleep period of 1 hour.
First all devices in operational mode waited up to send sensor data from device 'B' and 'C' to 'A' after cyclic period.

Here is one Issue:

When in between 'C' is turned off. For next cyclic period 'B' send data to 'A' and went to sleep and 'C' lost synchronization as it already turned off. Once again device 'C' is power ON, here it is waiting for synchronization with 'B' which is already in sleep under such condition the device 'C' will be wake up for 1 hour and will significantly draw battery until it getting back sync message from 'B' which is received from 'A'

Let me know what can be done so to avoid wasting of battery for 1 hour? As our Xbee is running with 3.3v coin cell battery and there is possibility where device can be turn on and off by user.
asked Aug 17 in XBee3 DigiMesh by ANOM New to the Community (1 point)

Please log in or register to answer this question.

2 Answers

+1 vote
ANOM,

If possible, configure node A (Sleep Coordinator) with Sleep Mode SM=7 (Sleep Support Mode). This will keep node A awake all the time and it can synchronize other nodes in network at any point of time whenever required.

Mathur
Digi Technical Support
answered Aug 21 by mathur Community Contributor (100 points)
Thank you for your reply.Currently our device 'A' configured with SM=7 but our concept is that device 'B' and 'C' should synchronize as soon as possible once powered on so we can increases life span of battery.
0 votes
What firmware version are you working with?
answered Aug 18 by mvut Veteran of the Digi Community (13,489 points)
Hi ,Its Firmware version is 3003
You will want to update your firmware as you are several versions behind.

Make sure that the coordinator has the proper SO option bit enabled and you have not disabled rapid sync for the end device or coordinator.
...