Home/Support/Support Forum/RealPort on Debian 10, problem with virtual devices
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

RealPort on Debian 10, problem with virtual devices

0 votes
For several years I successfully ran RealPort on a Debian 8 (jessie) machine. I am now trying to do the same on Debian 10 (buster). I have downloaded, built, and installed 1.9.40 on the new machine.

One change I see is the -g group requires an integer where before I put in the name. Notwithstanding that change, the following is what I used to run to initialize a virtual device.

sudo dgrp_cfg_node -v -p 772 -g 20 init AA 1.2.3.4 1

If I do the same now the device is created, but it does not reflect the desired group, or a file permission of 660.

lrwxrwxrwx 1 root root 13 Sep 15 09:50 /dev/ttyAA00 -> tty_dgrp_AA_0
crw
1 root root 244, 0 Sep 15 10:10 /dev/tty_dgrp_AA_0

If I run my script as sudo it works. If I manually change the ownership and permission of the device to

crw-rw---- 1 root dialout 244, 0 Sep 15 10:10 /dev/tty_dgrp_AA_0

I can run it as a regular user that is part of the dialout group.

I have tried changing values in /etc/dgrp.backing.store

How is it configured so the virtual devices are created with permissions 660 and group dialout?
asked Sep 15 in Realport by gary.hodges New to the Community (1 point)

Please log in or register to answer this question.

1 Answer

0 votes
As sometimes happens I discovered a solution shortly after posting the question. Started doing some diffs of previous dgrp files with those on the new system and found a significant difference with:

/etc/udev/rules.d/10-dgrp.rules

I changed the following:

KERNEL=="tty_dgrp*", PROGRAM="/usr/bin/dgrp_udev %k", SYMLINK+="%c", TAG="systemd"

to

KERNEL=="tty_dgrp*", PROGRAM="/usr/bin/dgrp_udev %k",SYMLINK+="%c", NAME="%c", GROUP="dialout",MODE="0660",OPTIONS="last_rule"

I'm curious if there is a better way or if something with Debian 10 instructions/configuration was left off? I only play a sys admin when I have to. This one took me a solid day. Excuse me while I pat myself on the back...
answered Sep 15 by gary.hodges New to the Community (1 point)
...