Home/Support/Support Forum/What parameter settings for XBP9B running the DP firmare in API mode for several nodes and one repeater

What parameter settings for XBP9B running the DP firmare in API mode for several nodes and one repeater

0 votes
We are using the XBP9B with the DP firmware running in API mode to try to provide communications between a small number of XBee-equipped computers located along a stretch of highway. We would like to use one or more repeaters to provide communication between the nodes when the work zone get too long, say 1 mile.

Basic master/slave command and ack communications between the nodes works. When they are in the immediate vicinity of one another, a high percentage of command-and-ack sequences complete successfully.

Once we add an off-the-shelf repeater to the mix, throughput drops dramatically, and only a small fraction of the commands complete successfully.

There are lockouts to insure only one command is active at a time, and the master waits for the slave to send its ack before moving on. This in hopes of avoiding packet collisions.

We are using the following parameters:
On the end points:
ID: <same on all units>
HP: 0
MT: 3
PL: 4
RR: 4
CE: 2
BH: 0
NH: 7
NN: 3
TO: 80
AP: 1

On the repeater, the parameters are the same, except for
CE: 0

All messages have TO=80

My question is: are these reasonable parameters for this configuration?

Any suggestions for diagnostics? E.g. can XCTU be used to listen in to API-mode non-broadcast packets?

Thanks,

jw
asked 4 days ago in Miscellaneous Hardware and Software by Jonathan Walther New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
No, you can't listen into none Broadcast packets.

The latency you see is normal as the timing does increase for every hop added. It will also reduce in throughput as well as the added hops does add more traffic.
answered 4 days ago by mvut Veteran of the Digi Community (13,318 points)
...