Home/Support/Support Forum/How to connect to XBee via serial terminal?

How to connect to XBee via serial terminal?

0 votes
I have two XBee modules connected to 2 PCs via usb using the XBee Grove Development boards.

I am able to connect with XCTU on both PCs and type messages back and forth. Everything works great.

What I'd like to do now is take XCTU out of the equation and send messages from one pc to another via a terminal program (Tera Term). I expected this to be simple, but I must be missing some step because I am unable to get any response from the boards in my terminal program. I've tried typing "+++" and still nothing.

Any ideas?
asked Oct 30 in Miscellaneous Hardware and Software by jtbourke New to the Community (1 point)

Please log in or register to answer this question.

1 Answer

0 votes
 
Best answer
The default baud rate is 9600, 8 data bits, No parity and 1 stop bit. You need to set up Tera Term to use the proper COM port and settings. That should be it.
answered Oct 30 by mvut Veteran of the Digi Community (13,491 points)
selected Oct 30 by jtbourke
I've done exactly that.  I see no response from the board in Tera Term, just a black screen.  I've tried it with two separate boards and two separate machines so I totally believe it is something I'm doing wrong.  I've reset the boards back to their default configuration.  Is there some additional step I'm missing?
You are not going to see anything unless you send data from the other side. Just like a wire or cable. Try sending or typing in one of the terminals. You should see it on the other.  If needed, use XCTU's console on one and hyper terminal or tera term on the other.
Ok I am able to send messages back and forth between two PCs in a terminal program now.  Thank you!  But I still don't understand why I cannot get a response by typing "+++".  Isn't that supposed to get an "OK" response?
Don't send a <CR> after the +++ and make sure  that the characters are within the guard time.
Ok that did the trick.  Thanks for the help!
...