Home/Support/Support Forum/Note that Qt no longer ships fonts. error in QT example
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Note that Qt no longer ships fonts. error in QT example

0 votes
Hi,

it is my first time with Digi and Yocto.

I tried to generate the QT example from the resources.

If i Run the QT HelloWorld example i get this error:
Note that Qt no longer ships fonts. Deploy some (from https://dejavu-fonts.github.io/ for example) or switch to fontconfig.

I tried some solutions from google but they did not work for me.

Device:
ConnectCore 6UL
dey3.0
QT Creator 4.13 Qt 5.13
compiled image dey-image-qt with DISTRO_FEATURES_remove = "x11"

It would be great, if anybody had a solution!!

Chris
asked Nov 30, 2020 in Linux by chrisk28 New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
try adding to local.conf:
IMAGE_INSTALL_append = "\
ttf-dejavu-sans \
ttf-dejavu-sans-mono \
ttf-dejavu-sans-condensed \
ttf-dejavu-serif \
ttf-dejavu-serif-condensed \
ttf-dejavu-common \
"
answered Dec 2, 2020 by LeonidM Veteran of the Digi Community (4,353 points)
...